PEAR is discontinued

This is a static archive preserving historical releases and metadata. No new packages or updates will be published. For updates to existing packages, or to publish new packages, please use Composer and Packagist.

Home » HTTP » HTTP » Bug #1748

Improper format of HTTP Date

Details

Submitted2004-06-30 11:15 UTC
Fromn dot dose at leo-media dot de
Assignedmike
StatusClosed
PackageHTTP
PHP Version4.2.2
OSLinux 2.4 (SUSE)
Roadmaps(Not assigned)

Comments

[2004-06-30 11:15 UTC] n dot dose at leo-media dot de

Description:
------------
The date output by HTTP::Date() is not formatted according to the HTTP spec with PHP 4.2.2, Linux 2.4.18, Apache 1.3.x.

BUT - it works with:
Linux 2.4.21, Apache 2 and PHP 4.3.3
SunOS 5.8, Apache 1.3 and PHP 4.3.6

Reproduce code:
---------------
<?php
include("/etc/phplib/HTTP.php");
echo HTTP::Date(time());
?>

Expected result:
----------------
One of the following formats (from HTTP spec):

Sun, 06 Nov 1994 08:49:37 GMT ; RFC 822, updated by RFC 1123
Sunday, 06-Nov-94 08:49:37 GMT ; RFC 850, obsoleted by RFC 1036
Sun Nov 6 08:49:37 1994 ; ANSI C's asctime() format

Actual result:
--------------
June, 30-Wed-04 10:59:51 GMT